Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 30, 2025 - 14:04 EDT
Scheduled
Dear Valued Client,
In order to continue to provide worldclass service and customer support, Evolve IP will be performing the following maintenance:
Start: 4/30/2025 2:00 PM EST End: 4/30/2025 4:00 PM EST Duration: 2h Purpose: XTIUM engineers will be upgrading Veeam Backup for M365 to the latest supported version. This will be a business hours upgrade to minimize impact on scheduled nightly backups. Impact: During the upgrade, Microsoft 365 backup and restore operations will be unavailable. Required user actions: No user interaction is required.
If you have any questions, please visit the Help Center portal at https://help.evolveip.net and submit a General Inquiry.
If you have an urgent incident, please call the Evolve IP Help Center at 877.459.4347, Option 2. Thank you for your attention and understanding.
Posted Apr 15, 2025 - 11:41 EDT
This scheduled maintenance affected: DRaaS (VE East).