ECS Impairment

Incident Report for XTIUM

Update

Applications have normalized and our engineers will monitor throughout the day for performance and stability.
Posted May 12, 2025 - 10:38 EDT

Identified

We have identified the cause of the disruption and are taking appropriate action to resolve.
Posted May 12, 2025 - 10:20 EDT

Investigating

We are aware that ECS functionality is impaired affecting a subset of clients; including but not limited to, status changes, delay in call delivery. Engineers are actively engaged.
Posted May 12, 2025 - 10:17 EDT
This incident affects: CCaaS (US) (ECS).