BroadWorks Call Center Wallboard Impairment

Incident Report for XTIUM

Resolved

Our engineers have completed monitoring and have confirmed that services have been restored. Accordingly, we have determined that this incident is resolved.
Posted May 02, 2025 - 14:55 EDT

Monitoring

XTIUM Engineers have identified the cause for BroadWorks Wallboard being unavailable and have resolved the issue. Engineering will monitor the rest of the day for continued operation.
Posted May 02, 2025 - 11:24 EDT

Investigating

XTIUM is currently aware of a service impairment with the BroadWorks Call Center Wallboard. Engineers are investigating.
Posted May 02, 2025 - 10:26 EDT
This incident affected: CCaaS (US) (Applications).